Mikrotik – LTE Passthrough HowTo

4. Mikrotik – Konfiguracja LTE passthrough z zarządzaniem

Wprowadzenie

Na potrzeby tego tutoriala zakładam, że masz urządzenie LTE ze stajni MT (w moim wypadku będzie to stary poczciwy SXT LTE) oraz drugie urządzenie MT na które będzie pracować jako router (w moim wypadku będzie to HAP AC2) skonfigurowany zgodnie z:
 
Pamiętajmy, że drugim urządzeniem nie musi być MT, może być każdy inny router (lub router + switch) obsługujący vlany.
Z tego wynika, że do pierwszego portu mamy wpięty kabel od naszego ISP (nasz główny WAN) a porty 2-5 są to porty LAN dodane do bridge1.
 

Założenia

Nasze urządzenie LTE (SXT LTE) będzie działało przeźroczyście i przydzieli adres od operatora LTE bezpośrednio na interfejs naszego routera (HAP AC2).
Jednocześnie zachowamy możliwość zarządzania SXT LTE.
W urządzeniu LTE wykorzystujemy ether1 a w HAP AC2 ether5.
 
  1. Konfiguracja management vlan i DHCP-Client
  2. Konfiguracja LTE passthrough
 

Usunięcie portu ether5 z bridge1 – LAN

Jeśli mamy router skonfigurowany zgodnie z powyższymi artykułami musimy usunąć interfejs ether5 (ponieważ będziemy do niego podłączać SXT LTE) z bridge1.
 
Bridge > Zakładka Ports > zaznaczamy ether5 > Remove (czerwony minus)
/interface bridge port remove numbers=3 

Chcemy usunąć port ether5 a nie 3 zatem skąd się wzięło 3? Z pomocą przyjdzie nam polecenie listujące wszystkie interfejsy dodane do bridge:

/interface bridge port print 

Korzystając z polecenia /interface bridge port remove numbers=3 podajemy jako wartość numbers wartość z kolumny zaznaczonej na czerwono. Widzimy, że dla interfejsu ether5 jest to 3 a dla wlan2 jest to 5. Wartość ta jest ustalana poprzez kolejność dodawania do bridge.

Konfiguracja management vlan

Dodajemy na SXT LTE vlan100_management (zarówno vlan tag w tym wypadku 100 jak i nazwa są dowolne, ja stosuje takie ze względu na swoje przyzwyczajenia)

Interfaces > ADD > VLAN

Name: vlan100_management

VLAN ID: 100

Interface: ether1 (ponieważ ten interfejs jest podłączony do HAP AC2)

/interface vlan add name=vlan100_management interface=ether1 vlan-id=100 

Ustawiamy na nowo powstałym interfejsie vlan100_management klienta DHCP

IP > DHCP Client > ADD

Interface: vlan100_management

/ip dhcp-client add interface=vlan100_management disabled=no 

Teraz logujemy się na nasz router (HAP AC2) i dodajemy vlan100_management na porcie ether5 (tym do którego mamy podłączony SXT LTE). Procedura jest podobna:

Interfaces > ADD > VLAN

Name: vlan100_management

VLAN ID: 100

Interface: ether5 (ponieważ ten interfejs jest podłączony do SXT LTE)

A następnie dodajemy vlan100_management do bridge1

Bridge > Ports > ADD

Interface: vlan100_management

/interface vlan add name=vlan100_management interface=ether5 vlan-id=100
/interface bridge port add bridge=bridge1 interface=vlan100_management 

Jeśli wszystko wykonaliśmy poprawnie SXT LTE powinno otrzymać na interfejsie vlan100_management adres z serwera DHCP uruchomionego na bridge1 w HAP AC2.

Sprawdźmy czy tak się stało.

Na SXT LTE:

IP > Addresses

Działa! Otrzymaliśmy adres 172.16.0.251, warto według mnie ustawić statyczną dzierżawę adresu na serwerze DHCP. Ponieważ ja lubię adresacje urządzeń po kolei zmienię statyczny wpis w taki sposób aby SXT LTE zawsze dostawało 172.16.0.2.

Na HAP AC2:

Aby przyspieszyć otrzymanie nowego adresu na SXT LTE wykonuję następującą czynność wywołując zapytanie do serwera DHCP:

/ip dhcp-client renew numbers=0 

Wszystko działa jak należy. Widać, że po odświeżeniu dzierżawy dostaliśmy adres 172.16.0.2, dokładnie taki jak chcieliśmy. Możemy przystąpić do dalszej konfiguracji.

 

Konfiguracja LTE passthrough

Mamy działający vlan który będziemy używać do łączenia się z naszym urządzeniem za pomocą winbox. Teraz czas skonfigurować interfejs lte1 na SXT LTE.Zacznę od sprawdzenia czy nasze połączenie LTE działa bez trybu passthrough a następnie przełaczymy je do trybu docelowego.
 
Moja karta z Orange wymaga podania pinu do odblokowania.
 
Interfaces > zakładka LTE > przycisk LTE APNs
W oknie klikamy dwukrotnie na domyślny profil default i edytujemy APN (apn jest różny dla różnych dostawców i usług. Jeśli nie mamy wykupionej usługi publicznego adresu IP zazwyczaj będzie to internet, jeśli mamy np. dla Orange jest to vpn.static.pl) Pokazuję tą opcje ponieważ dużo osób na swoich kartach SIM ma wykupione publiczne adresy IP i dlatego chcieliby zrobić passthrough.
Następnie wchodzimy we właściwości interfejsu lte1 dwukrotnie na niego klikając i w polu PIN podajemy PIN do karty SIM. Zatwierdzamy OK i sprawdzamy czy uzyskaliśmy połączenie i posiadamy adres IP na interfejsie lte1.

 

/interface lte set lte1 pin=<tutaj podajemy nasz pin> 

Widać, że na interfejsie lte1 uzyskaliśmy adres od operatora LTE. Wyjątkowo nie trzeba na lte1 dodawać DHCP-Clienta aby otrzymać adres.

Zatem zróbmy teraz passthrough LTE na naszego HAP AC2.

Wróćmy się jeszcze raz do

Interfaces > LTE > LTE APNs

i ponownie wyedytujmy domyślny profil default. Tym razem skonfigurujmy opcje:

Passthrough Interface: ether1 (ten port łączy nas z HAP AC2)

A od strony HAP AC2 dodajmy DHCP-Client na porcie ether5 (łączącym nas z SXT LTE)

IP > DHCP Client > ADD

Interface: ether5 (ten który podłączony jest do SXT LTE)

Jeśli LTE nie jest naszym głównym łączem i nie chcemy aby cały ruch domyślnie był przez nie wypuszczany (czyli mamy drugie łącze) Add Default Route ustawiamy na no w przeciwnym wypadku zostawiamy yes żeby domyślna brama się dodała.

/ip dhcp-client add interface=ether5 disabled=no 

Po tej operacji na ether5 w HAP AC2 będziemy mieli adres IP przydzielany przez operatora LTE który został przekazany przez SXT LTE.

Sprawdźmy jeszcze czy skoro włączyliśmy passthrough mamy dostęp do naszego SXT LTE.

Winbox wykrywa oba urządzenia, możemy się zalogować również do obu a z HAP AC2 możemy pingować SXT LTE. Zatem osiągnęliśmy sukces, wszystko działa jak należy.

5 thoughts on

Mikrotik – LTE Passthrough HowTo

  • Artur

    Wszystko działa jak należy 🙂 Swietne artykuły, a temat z passthrough lte wstawiony w idealnym dla mnie momencie 🙂 Czekam na więcej 🙂

  • Arek

    Super artykuł. Właśnie na taki czekałem. W sieci poradników jak skonfigurować passthrough jest jak na lekarstwo i są nieprecyzyjne. Tutaj wszystko podane na tacy krok po kroku. Tak trzymaj Damian! Brakuje mi tylko informacji czy poza tym, co opisałeś w artykule, na SXT powinna być wykonana jeszcze jakakolwiek konfiguracja (np. Cloud, Firewall itp.)?

  • Marcin

    Witam. Napisałem do Pana maila w sprawie pomocy w konfiguracji . Z góry dziękuje za odpowiedz

  • Radek

    Artykuł bardzo fajny, niestety dla mnie laika jeśli chodzi o MikroTik, niestety mimo kilku prób na podobnym sprzęcie bo hAP AC3 oraz LHG LTE6, nie udało się mnie uruchomić internetu na routerze. Wygląda to zasadniczo tak jakby router miał Internet, ale nie przekazywał go dalej.

    Oprócz tego fajnie było by znaleźć tutaj na blogu artykuł o konfiguracji z tym routerem np. dodatkowego AP, który by rozgłaszał w innej części domu tą samą sieć wifi.

    • Damian

      Czy z routera mozesz pingować jakas domene? Np. Wp.pl ?
      Jesli tak, pokaz co masz w ip firewall nat. Myślę, ze zabrakło maskrady.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

Podoba Ci się blog?
Zapisz się do newslettera.

Wpisz swój adres żeby nie ominąć nowego artykułu.
Z przyjemnością Cię o nim poinformuje.
Nie przejmuj się, nigdy nie wyśle Ci żadnego spamu.